Skip to main content

DMVPN - phase one - EIGRP

Today I would like to implement DMVPN with EIGRP. This protocol is very popular because of its scalability. Please read this post before you start because I’m not going to implement it from scratch:
http://myitmicroblog.blogspot.com/2014/12/dmvpn-phase-one-ospf.html
I assume you have your hub and spoke router configured (IP addressing, hub and spoke configuration, firewall rules).

dmvpn-1-1.jpg
I have to add following configuration:

R1:

!
router eigrp 1
 network 10.10.10.0 0.0.0.255
 network 11.11.11.0 0.0.0.255
 auto-summary
!
interface Tunnel0
 no ip split-horizon eigrp 1
!

R2:
 
!
router eigrp 1
 network 10.10.10.0 0.0.0.255
 network 22.22.22.0 0.0.0.255
 no auto-summary
!
interface Tunnel0
 ip address 10.10.10.2 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication cisco
 ip nhrp map multicast 5.5.5.1
 ip nhrp map 10.10.10.1 5.5.5.1
 ip nhrp network-id 12
 ip nhrp nhs 10.10.10.1
 ip nhrp cache non-authoritative
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 12
 tunnel protection ipsec profile IPSEC-PRF
!

R3:
 
!
router eigrp 1
 network 10.10.10.0 0.0.0.255
 network 33.33.33.0 0.0.0.255
 no auto-summary
!
interface Tunnel0
 ip address 10.10.10.3 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication cisco
 ip nhrp map multicast 5.5.5.1
 ip nhrp map 10.10.10.1 5.5.5.1
 ip nhrp network-id 12
 ip nhrp nhs 10.10.10.1
 ip nhrp cache non-authoritative
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
 tunnel key 12
 tunnel protection ipsec profile IPSEC-PRF
!

As you know the phase 1 allows only on hub-spoke communication. I’m going now to test connectivity between R2 and R3.
 

R2#sh ip nhrp
10.10.10.1/32 via 10.10.10.1, Tunnel0 created 00:03:18, never expire
  Type: static, Flags: nat used
  NBMA address: 5.5.5.1
R2#
R2#sh ip route eigrp
     33.0.0.0/24 is subnetted, 1 subnets
D       33.33.33.0 [90/310172416] via 10.10.10.1, 00:03:36, Tunnel0
D    11.0.0.0/8 [90/297372416] via 10.10.10.1, 00:03:36, Tunnel0 
R2#
 
 
R2#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.10.10.1              Tu0               13 00:03:54  132  5000  0  27
R2#
 
 
R2#sh dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incompletea
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer

Tunnel0, Type:Spoke, NHRP Peers:1,
 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1         5.5.5.1      10.10.10.1    UP 00:04:08 S

R2#
 
 
R2#sh dmvpn detail
Legend: Attrb --> S - Static, D - Dynamic, I - Incompletea
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer

 -------------- Interface Tunnel0 info: --------------
Intf. is up, Line Protocol is up, Addr. is 10.10.10.2
   Source addr: 6.6.6.1, Dest addr: MGRE
  Protocol/Transport: "multi-GRE/IP", Protect "IPSEC-PRF",
Tunnel VRF "", ip vrf forwarding ""

NHRP Details: NHS:         10.10.10.1 RE

Type:Spoke, NBMA Peers:1
# Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb    Target Network
----- --------------- --------------- ----- -------- ----- -----------------
    1         5.5.5.1      10.10.10.1    UP 00:04:47 S         10.10.10.1/32

  IKE SA: local 6.6.6.1/500 remote 5.5.5.1/500 Active
  Crypto Session Status: UP-ACTIVE
  fvrf: (none)
  IPSEC FLOW: permit 47 host 6.6.6.1 host 5.5.5.1
        Active SAs: 2, origin: crypto map
   Outbound SPI : 0x72F083DD, transform : esp-3des esp-sha-hmac
    Socket State: Open

Pending DMVPN Sessions:

R2#

Now I send traffic from R2 to R3:
 
R2#traceroute 33.33.33.33 source 22.22.22.22

Type escape sequence to abort.
Tracing the route to 33.33.33.33

  1 10.10.10.1 76 msec 36 msec 100 msec
  2 10.10.10.3 88 msec 88 msec 72 msec
R2# 
 
R2#traceroute 33.33.33.33 source 22.22.22.22

Type escape sequence to abort.
Tracing the route to 33.33.33.33

  1 10.10.10.1 68 msec 44 msec 60 msec
  2 10.10.10.3 100 msec 96 msec 64 msec
R2#

Traffic is sent over the hub (as expected) and any dynamic tunnels are created:
 
R2#sh ip nhrp
10.10.10.1/32 via 10.10.10.1, Tunnel0 created 00:06:29, never expire
  Type: static, Flags: nat used
  NBMA address: 5.5.5.1
R2#
 
R2#sh dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incompletea
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer

Tunnel0, Type:Spoke, NHRP Peers:1,
 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1         5.5.5.1      10.10.10.1    UP 00:06:33 S

R2#

In some cases companies prefer to use only hub-spoke communication and for them the phase one is the best option. For those who want to save their hub resources and allow on spoke-to-spoke communication the phase 2 (not recommended) and phase 3 are a good option. In my next post I will implement the phase 2 for EIGRP.

Comments

Popular posts from this blog

What should you know about HA 'override enabled' setting on Fortigate?

High availability is mandatory in most of today's network designs. Only very small companies or branches can run their business without redundancy. When you have Fortigate firewall in your network you have many options to increase network availability. You can use Fortigate Clustering Protocol ( FGCP ) or Virtual Router Redundancy Protocol ( VRRP ). FGCP has two modes: 'override' disabled (default) and 'override' enabled . I'm not going to explain how to set up HA as you can find many resources on Fortinet websites: https://cookbook.fortinet.com/high-availability-two-fortigates-56/ https://cookbook.fortinet.com/high-availability-with-fgcp-56/ Let's recap what is the main difference between them. The default HA setting is 'override' disabled and this is an order of selection an active unit: 1) number of monitored interfaces - when both units have the same number of working (up) interfaces check next parameter 2) HA uptime - an

MAC Authentication Bypass

One of the method to control your network is using MAB feature. It is helpful in case you have devices without dot1x functionality. Today I will try to implement basic configuration and analyze log messages. There is only one switch SW1 and one device attached to port Fa1/0/2.   ! aaa new - model aaa authentication dot1x default group radius ! ! int Fas1 / 0 / 2 authentication host - mode single - host authentication port - control auto mab ! I haven’t configured ACS yet but let’s see what error message I receive:   SW1 ( config - if ) # mab - ev ( Fa1 / 0 / 2 ): Received MAB context create from AuthMgr mab - ev ( Fa1 / 0 / 2 ): Created MAB client context 0x1100000F mab : initial state mab_initialize has enter mab - ev ( Fa1 / 0 / 2 ): Sending create new context event to EAP from MAB for 0x1100000F ( 0000.0000 . 0000 ) mab - sm ( Fa1 / 0 / 2 ): Received event 'MAB_START' on handle 0x1100000F mab : during state mab_initia

Inpection of asymmetric sessions on FortiGate

There is one feature available on FortiGate, and I think you should know it, as it modifies a bit what we know about stateful firewalls. In past every packet was treated individually and you had to create policies in both directions. With stateful firewalls we can track connections, and by checking couple of attributes, we can treat them as part of the same session. For example when you initiate connection from a host1 to host2, the returning connection from host2 to host1 will be treated as part of the same connection (session). They have to have the same source/destination and destination/source IPs, port numbers and interfaces.There is an exception from this rule and FortiGate in some specific cases can accept connections on port which was not used in the initial connection. Let me explain how it works on the below example:      The host1 has a default gateway on R1 (10.0.1.2), but you may notice that it is not the optimal path to host2 subnet. When we analyze the packet flo