Skip to main content

Zone Base Firewall Policy

ZBFP is a successor of CBAC and it is the most flexible firewall implementation available on IOS. The main idea is to think about zones, not physical interfaces. With CBAC you couldn’t build policy based on flow or direction. For example a policy applied on OUTSIDE interface works the same for traffic to DMZ and to LAN. ZBFP can easily separate these flows and you can have two different rules depending on out interface. Let’s test one scenario:

zbfp1.jpg

I’m going to add a policy for traffic from R2 to R3. Only telnet and icmp should be allowed.
First I create a class and policy map:
 
!
class-map type inspect match-any CM-ICMP-TCP
 match protocol icmp
 match protocol tcp
!
policy-map type inspect PM-ICMP-TCP
 class type inspect CM-ICMP-TCP
  inspect
 class class-default
!

and then zones and a service policy:
 
!
zone security INSIDE
zone security OUTSIDE
!
zone-pair security INS->OUT source INSIDE destination OUTSIDE
 service-policy type inspect PM-ICMP-TCP
!

Last step is to add interfaces to the zones:
 
!
interface FastEthernet0/0
 ip address 5.5.5.1 255.255.255.0
!
interface FastEthernet1/0
 ip address 4.4.4.1 255.255.255.0
 zone-member security OUTSIDE
!
interface FastEthernet1/1
 ip address 2.2.2.1 255.255.255.0
 zone-member security INSIDE
!
interface FastEthernet2/0
 ip address 3.3.3.1 255.255.255.0
!

As you see only two interfaces are part of ZBFP configuration. Let’s test it:
 
R2#telnet 4.4.4.3
Trying 4.4.4.3 ... Open


Password required, but none set

[Connection to 4.4.4.3 closed by foreign host]
R2#
R2#ping 4.4.4.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 256/273/320 ms
R2#

On the R1 we can see following sessions:
 
R1#sh policy-map type inspect zone-pair sessions
 Zone-pair: INS->OUT

  Service-policy inspect : PM-ICMP-TCP

    Class-map: CM-ICMP-TCP (match-any)
      Match: protocol icmp
        1 packets, 80 bytes
        30 second rate 0 bps
      Match: protocol tcp
        2 packets, 48 bytes
        30 second rate 0 bps
      Inspect
        Established Sessions
         Session 6672C230 (2.2.2.2:8)=>(4.4.4.3:0) icmp SIS_OPEN
          Created 00:00:05, Last heard 00:00:04
           ECHO request
          Bytes sent (initiator:responder) [360:360]

    Class-map: class-default (match-any)
      Match: any
      Drop (default action)
        0 packets, 0 bytes
R1#
and
R1#sh policy-map type inspect zone-pair sessions
 Zone-pair: INS->OUT

  Service-policy inspect : PM-ICMP-TCP

    Class-map: CM-ICMP-TCP (match-any)
      Match: protocol icmp
        1 packets, 80 bytes
        30 second rate 0 bps
      Match: protocol tcp
        4 packets, 96 bytes
        30 second rate 0 bps
      Inspect
        Established Sessions
         Session 6672C230 (2.2.2.2:19243)=>(4.4.4.3:23) tcp SIS_OPEN
          Created 00:00:00, Last heard 00:00:00
          Bytes sent (initiator:responder) [24:49]

    Class-map: class-default (match-any)
      Match: any
      Drop (default action)
        0 packets, 0 bytes
R1#

As you can see the policy works as expected. Let’s test now if traffic between interfaces which are not part of ZBFP is allowed (R5->R4) and if traffic between zone member and non-zone member is allowed (R2->R4).

R5->R4:
 
R5#ping 5.5.5.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 132/166/224 ms
R5#telnet 5.5.5.4
Trying 5.5.5.4 ... Open


Password required, but none set

[Connection to 5.5.5.4 closed by foreign host]
R5#

R2->R4:
 
R2#ping 5.5.5.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R2#
R2#telnet 5.5.5.4
Trying 5.5.5.4 ...
% Connection timed out; remote host not responding

R2#

Conclusions:

1) if you have interfaces that are members of zones, traffic from/to interface that is not part of any zone and such zone pair doesn’t exist, is not allowed

2) if you have a ZBFP configured on router, traffic between interfaces that are not members of any zone is not controlled by the ZBFP and by default is permitted.

Comments

Popular posts from this blog

What should you know about HA 'override enabled' setting on Fortigate?

High availability is mandatory in most of today's network designs. Only very small companies or branches can run their business without redundancy. When you have Fortigate firewall in your network you have many options to increase network availability. You can use Fortigate Clustering Protocol ( FGCP ) or Virtual Router Redundancy Protocol ( VRRP ). FGCP has two modes: 'override' disabled (default) and 'override' enabled . I'm not going to explain how to set up HA as you can find many resources on Fortinet websites: https://cookbook.fortinet.com/high-availability-two-fortigates-56/ https://cookbook.fortinet.com/high-availability-with-fgcp-56/ Let's recap what is the main difference between them. The default HA setting is 'override' disabled and this is an order of selection an active unit: 1) number of monitored interfaces - when both units have the same number of working (up) interfaces check next parameter 2) HA uptime - an

MAC Authentication Bypass

One of the method to control your network is using MAB feature. It is helpful in case you have devices without dot1x functionality. Today I will try to implement basic configuration and analyze log messages. There is only one switch SW1 and one device attached to port Fa1/0/2.   ! aaa new - model aaa authentication dot1x default group radius ! ! int Fas1 / 0 / 2 authentication host - mode single - host authentication port - control auto mab ! I haven’t configured ACS yet but let’s see what error message I receive:   SW1 ( config - if ) # mab - ev ( Fa1 / 0 / 2 ): Received MAB context create from AuthMgr mab - ev ( Fa1 / 0 / 2 ): Created MAB client context 0x1100000F mab : initial state mab_initialize has enter mab - ev ( Fa1 / 0 / 2 ): Sending create new context event to EAP from MAB for 0x1100000F ( 0000.0000 . 0000 ) mab - sm ( Fa1 / 0 / 2 ): Received event 'MAB_START' on handle 0x1100000F mab : during state mab_initia

Inpection of asymmetric sessions on FortiGate

There is one feature available on FortiGate, and I think you should know it, as it modifies a bit what we know about stateful firewalls. In past every packet was treated individually and you had to create policies in both directions. With stateful firewalls we can track connections, and by checking couple of attributes, we can treat them as part of the same session. For example when you initiate connection from a host1 to host2, the returning connection from host2 to host1 will be treated as part of the same connection (session). They have to have the same source/destination and destination/source IPs, port numbers and interfaces.There is an exception from this rule and FortiGate in some specific cases can accept connections on port which was not used in the initial connection. Let me explain how it works on the below example:      The host1 has a default gateway on R1 (10.0.1.2), but you may notice that it is not the optimal path to host2 subnet. When we analyze the packet flo