Skip to main content

VPN - GRE over IPsec SSO

As I promised in my last post I will add the stateful switchover to the following scenario:

blog-gre-over-ipsec3.jpg
The first step is to remove tunnel1 from r5 and r4 and then add tunnel0 on r4. Next implementation of HSRP and changing ‘tunnel source’ on r3 and r4:

R4:
 
!
ipc zone default
association 1
  no shutdown
  protocol sctp
   local-port 5000
    local-ip 10.1.0.4
   remote-port 5000
    remote-ip 10.1.0.3
!
redundancy inter-device
scheme standby VPN
!
!
interface FastEthernet0/1
ip address 10.1.0.4 255.255.255.0
standby 0 ip 10.1.0.100
standby 0 preempt
standby 0 name VPN
standby 0 track 1 decrement 10
standby 0 track 2 decrement 10
standby 0 track 3 decrement 10
!
!
interface Tunnel0
ip address 7.7.7.4 255.255.255.0
tunnel source 10.1.0.100
tunnel destination 10.1.0.5
tunnel protection ipsec profile IPSEC-PRF
!

R3:
 
!
ipc zone default
association 1
  no shutdown
  protocol sctp
   local-port 5000
    local-ip 10.1.0.3
   remote-port 5000
    remote-ip 10.1.0.4
!
redundancy inter-device
scheme standby VPN
!
!
interface FastEthernet1/0
ip address 10.1.0.3 255.255.255.0
standby 0 ip 10.1.0.100
standby 0 preempt
standby 0 name VPN
standby 0 track 1 decrement 10
standby 0 track 2 decrement 10
standby 0 track 3 decrement 10
!
!
interface Tunnel0
ip address 7.7.7.3 255.255.255.0
tunnel source 10.1.0.100
tunnel destination 10.1.0.5
tunnel protection ipsec profile IPSEC-PRF
!

Let’s check the redundancy status:
 
r3#sh redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_HSRP_STDBY_PNC
  Scheme: Standby
      Groupname: VPN Group State: Standby
  Peer present: UNKNOWN
  Security: Not configured
r3#
 
r4#sh redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
  Scheme: Standby
      Groupname: VPN Group State: Active
  Peer present: RF_INTERDEV_PEER_NO_COMM
  Security: Not configured
r4#

and the last step to make the VPN aware of the stateful feature (on both peers r3 and r4):
 
!
crypto ipsec profile IPSEC-PRF
set transform-set TS
redundancy VPN stateful
!

Now on r5 we need to change tunnel destination to VIP IP 10.1.0.100:
 
r5#sh run int tun0
Building configuration...

Current configuration : 164 bytes
!
interface Tunnel0
ip address 7.7.7.5 255.255.255.0
tunnel source FastEthernet0/1
tunnel destination 10.1.0.100
tunnel protection ipsec profile IPSEC-PRF
end

Let’s test the switchover.

When I sent the traffic from r6 to r12 I see the log message on the standby peer:
 
r3#
*Nov 21 02:57:32.823: IKE HA: (10.1.0.100) Adding STANDBY IKE SA

*Nov 21 02:57:32.831: IKE HA: Create peer struct for local 104.26.189.68 remote 104.26.189.40 & locked
*Nov 21 02:57:32.839: IKE HA: IKE SA inserted on standby with src = 10.1.0.100, dst   = 10.1.0.5

r3#

Let’s check if we see any SA:
 
r3#sh crypto isakmp sa d
Codes: C - IKE configuration mode, D - Dead Peer Detection
       K - Keepalives, N - NAT-traversal
       T - cTCP encapsulation, X - IKE Extended Authentication
       psk - Preshared key, rsig - RSA signature
       renc - RSA encryption
IPv4 Crypto ISAKMP SA

C-id  Local           Remote          I-VRF  Status Encr Hash   Auth DH Lifetime Ca                           p.

1011  10.1.0.100      10.1.0.5               STDBY  3des sha    psk  5  23:59:37                              
       Engine-id:Conn-id =  SW:11

IPv6 Crypto ISAKMP SA

r3#

Ok, we see ‘STDBY’ status what means it is waiting and ready for the switchover.

Comments

Popular posts from this blog

What should you know about HA 'override enabled' setting on Fortigate?

High availability is mandatory in most of today's network designs. Only very small companies or branches can run their business without redundancy. When you have Fortigate firewall in your network you have many options to increase network availability. You can use Fortigate Clustering Protocol ( FGCP ) or Virtual Router Redundancy Protocol ( VRRP ). FGCP has two modes: 'override' disabled (default) and 'override' enabled . I'm not going to explain how to set up HA as you can find many resources on Fortinet websites: https://cookbook.fortinet.com/high-availability-two-fortigates-56/ https://cookbook.fortinet.com/high-availability-with-fgcp-56/ Let's recap what is the main difference between them. The default HA setting is 'override' disabled and this is an order of selection an active unit: 1) number of monitored interfaces - when both units have the same number of working (up) interfaces check next parameter 2) HA uptime - an

MAC Authentication Bypass

One of the method to control your network is using MAB feature. It is helpful in case you have devices without dot1x functionality. Today I will try to implement basic configuration and analyze log messages. There is only one switch SW1 and one device attached to port Fa1/0/2.   ! aaa new - model aaa authentication dot1x default group radius ! ! int Fas1 / 0 / 2 authentication host - mode single - host authentication port - control auto mab ! I haven’t configured ACS yet but let’s see what error message I receive:   SW1 ( config - if ) # mab - ev ( Fa1 / 0 / 2 ): Received MAB context create from AuthMgr mab - ev ( Fa1 / 0 / 2 ): Created MAB client context 0x1100000F mab : initial state mab_initialize has enter mab - ev ( Fa1 / 0 / 2 ): Sending create new context event to EAP from MAB for 0x1100000F ( 0000.0000 . 0000 ) mab - sm ( Fa1 / 0 / 2 ): Received event 'MAB_START' on handle 0x1100000F mab : during state mab_initia

Inpection of asymmetric sessions on FortiGate

There is one feature available on FortiGate, and I think you should know it, as it modifies a bit what we know about stateful firewalls. In past every packet was treated individually and you had to create policies in both directions. With stateful firewalls we can track connections, and by checking couple of attributes, we can treat them as part of the same session. For example when you initiate connection from a host1 to host2, the returning connection from host2 to host1 will be treated as part of the same connection (session). They have to have the same source/destination and destination/source IPs, port numbers and interfaces.There is an exception from this rule and FortiGate in some specific cases can accept connections on port which was not used in the initial connection. Let me explain how it works on the below example:      The host1 has a default gateway on R1 (10.0.1.2), but you may notice that it is not the optimal path to host2 subnet. When we analyze the packet flo