Skip to main content

CCIE-LAB-RTBH

I - DESTINATION BASED

ATTACKER:
 
R1:
router rip
 version 2
 no auto-summary
 network 136.1.0.0
 network 150.1.0.0

TRIGGER:
 
R2:
router rip
 version 2
 no auto-summary
 network 136.1.0.0
 network 150.1.0.0
!
router bgp 23
 neighbor 136.1.23.3 remote-as 23
 neighbor 136.1.23.3 send-community
 redistribute static route-map STATIC_TO_BGP
!
route-map STATIC_TO_BGP permit 10
 match tag 23
 set local-preference 200
 set origin igp
 set community no-export
 set ip next-hop 192.0.2.1
!
ip route 192.0.2.1 255.255.255.255 Null0

when attack start add below acl (with IP of the destination - local server):
 
ip route 10.1.0.100 255.255.255.255 Null0 tag 23

EDGE:
 
R3:
router rip
 version 2
 no auto-summary
 network 136.1.0.0
 network 150.1.0.0
 network 10.0.0.0
!
router bgp 23
 neighbor 136.1.23.2 remote-as 23
!
ip route 192.0.2.1 255.255.255.255 Null0
!
interface Null0
 no ip unreachables

I - SOURCE BASED

TRIGGER:

when attack start add below acl (with source IP of the attacker):
 
ip route 170.170.170.170 255.255.255.255 Null0 tag 23

EDGE:
 
interface FastEthernet0/0.13
 ip verify unicast source reachable-via any

For networks which are not in the routing table or the next hop is Null0 - they are silently dropped.

Comments

Popular posts from this blog

What should you know about HA 'override enabled' setting on Fortigate?

High availability is mandatory in most of today's network designs. Only very small companies or branches can run their business without redundancy. When you have Fortigate firewall in your network you have many options to increase network availability. You can use Fortigate Clustering Protocol ( FGCP ) or Virtual Router Redundancy Protocol ( VRRP ). FGCP has two modes: 'override' disabled (default) and 'override' enabled . I'm not going to explain how to set up HA as you can find many resources on Fortinet websites: https://cookbook.fortinet.com/high-availability-two-fortigates-56/ https://cookbook.fortinet.com/high-availability-with-fgcp-56/ Let's recap what is the main difference between them. The default HA setting is 'override' disabled and this is an order of selection an active unit: 1) number of monitored interfaces - when both units have the same number of working (up) interfaces check next parameter 2) HA uptime - an

MAC Authentication Bypass

One of the method to control your network is using MAB feature. It is helpful in case you have devices without dot1x functionality. Today I will try to implement basic configuration and analyze log messages. There is only one switch SW1 and one device attached to port Fa1/0/2.   ! aaa new - model aaa authentication dot1x default group radius ! ! int Fas1 / 0 / 2 authentication host - mode single - host authentication port - control auto mab ! I haven’t configured ACS yet but let’s see what error message I receive:   SW1 ( config - if ) # mab - ev ( Fa1 / 0 / 2 ): Received MAB context create from AuthMgr mab - ev ( Fa1 / 0 / 2 ): Created MAB client context 0x1100000F mab : initial state mab_initialize has enter mab - ev ( Fa1 / 0 / 2 ): Sending create new context event to EAP from MAB for 0x1100000F ( 0000.0000 . 0000 ) mab - sm ( Fa1 / 0 / 2 ): Received event 'MAB_START' on handle 0x1100000F mab : during state mab_initia

Inpection of asymmetric sessions on FortiGate

There is one feature available on FortiGate, and I think you should know it, as it modifies a bit what we know about stateful firewalls. In past every packet was treated individually and you had to create policies in both directions. With stateful firewalls we can track connections, and by checking couple of attributes, we can treat them as part of the same session. For example when you initiate connection from a host1 to host2, the returning connection from host2 to host1 will be treated as part of the same connection (session). They have to have the same source/destination and destination/source IPs, port numbers and interfaces.There is an exception from this rule and FortiGate in some specific cases can accept connections on port which was not used in the initial connection. Let me explain how it works on the below example:      The host1 has a default gateway on R1 (10.0.1.2), but you may notice that it is not the optimal path to host2 subnet. When we analyze the packet flo